0 votes
60 views
by (16 points)
When trying to answer a question if you go over the character limit you get a message of "Maximum length is 20000 characters". My issue with this is I often run across this issue with adding tables or images into an answer. I had the problem again today. My answer had under 500 characters with 2 images added.

To resolve this I generally have to copy my content out into notepad or a word document, refresh the page, add a new answer. Then paste my content back in and re add tables or images then it will resolve itself. If I don't navigate away and just try to delete images, tables, and white space, I still have the error message.

I was wondering if it was known what causes this specifically, does it affect other people, and if it could be resolved?
by (2,429 points)
I know that there might be a problem when you try to copy/paste images directly into the input, instead of via the image upload button. When you copy/paste it directly into the post, it converts the image to Base64 -https://en.wikipedia.org/wiki/Base64 which is a looong text that essentially stores this image.

With tables, there's also a small number of characters required to hold the information about this table. With regularly-sized tables, there are usually no bigger issues. However, each new row and each new column is a little bit of additional information to store. The problem is bigger when you copy/paste tavbles from other sources - it usually also copies over their styling information that also occupies quite some space. Creating tables via our editor consumes fewer characters.
by (16 points)
It probably is a copy/paste issue. It just becomes very unclear how to submit the answer without just starting from scratch. Even if you strip stuff out of your answer then try to submit can still run into issues. Anyways, I will try to make sure to avoid pasting images directly and hopefully that resolves most issues.
by (2,429 points)
Please don't hesitate to reach out if you still encounter issues, despite not doing any copy/paste. I'll also see if I can somehow make the copy/paste work better.
by (16 points)
Maybe it should be it's own thread brought up but you can't right click in the editor at all. It works here when adding a comment but in the WYSIWYG you lose the ability to correct words that are spelled incorrectly or "Paste as plain text", etc

1 Answer

0 votes
by (564 points)
With me I know this error occurs when I copy and paste sometimes. I guess if the format is different than what's accepted by TibiaQA sometimes it can cause the error? I don't experience it any other time nor have I experienced it recently because I just try to make my own charts using TibiaQA tools and fill them in. I think Ellotris should confirm why this can happen.
...